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Membahas teknik pembuatan aplikasi database menggunakan Microsoft Access Project 2003 dan SQL
Server 2000. Pada buku ini diberikan 101 teknik menggunakan Microsoft Access Project yang
merupakan bagian dari Microsoft Access sebagai front end atau antarmuka program aplikasi dan SQL
Server 2000 sebagai back end atau database.

Dengan menggunakan SQL Server 2000 sebagai database maka program database yang dibuat menjadi
lebih andal. Selain itu dibahas salah satu bagian dari Microsoft Access yang dapat kita gunakan untuk
berkolaborasi dengan database yang lain yaitu Microsoft Access Project. Dengan menggunakan
Microsoft Access Project maka kita dapat membuat program aplikasi dengan lebih mudah.

Materi mencakup tip dan trik database, tabel, koneksi database, form, report, view, macro, dan
stored procedure. Pembahasan dirancang sesederhana mungkin agar mudah dipahami.
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Membuat Tabel dari Enterprise
Manager

Cara membuat sebuah tabel menggunakan Enterprise
Manager sebagai berikut:

1. Pada Enterprise Manager, pilih database yang akan di-
gunakan.

2. Klik-kanan pada ikon Tables kemudian klik pada menu
New Table.

mXERB R[N EE
Tree | LatihanSQL 11 Items
[ Consale Root - !
B8] Micrasoft 5QL Servers = ﬁu" aﬂ
1 5L Server Group Diagrams fTbles] Yiews Stored

E-fEly local) (windows HT)
=] Databases

EI | Al Tasks 3 Ef'

HNew Windaw from Here

Refresh i

Help

24 stored Procedures

Gambar 2.1. Ikon Tables
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3. Selanjutnya isi nama field, tipe data dan ukuran dari field
tabel pada field editor tabel dan simpan tabel tersebut.

"Hi 2:New Table in "LatihanSQL" on ‘(local)’

HE B =207 &5 s E

CoumnMame | DataType  |Length| Allow Hulls
Kode char 10 W
[ |Mama char 30 Y
T Bagian char 10 W
I Gaji decimal el W
Colurnns
Description
Default Yalue
Precision 15
Scale a
Identity Mo

Gambar 2.2. Field Editor dari Tabel

13

Membuat Tabel dari Query
Analyzer

Cara membuat sebuah tabel menggunakan Query Analyzer
sebagai berikut:

1. Sebagai contoh jika Anda ingin membuat tabel dengan
nama tbPegawai dan memiliki empat buah field yaitu
Kode, Nama, Alamat, dan Gaji, maka contoh kode
programnya terlihat seperti pada Gambar 2.3.
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ii" Query - HENGKY.master. HENGKY' Administ

=10 =]

4]

/ *Hama Database vang digunakan®/

Use Northwind

CREATE TABLE thPegawai

(

Eode Chari(5),

Nawa Char (25) NOT NULL,

A lamat

Char {25) NOT NULL,

Gaji Numeric MOT NULL

!

il

IHE HENGKY | Administrator (53) [master | 0:00:00

14

Orows [n4,Calz 4

Gambar 2.3.Membuat Sebuah Tabel

Mengurutkan Record Tabel pada

Bentuk Datasheet View

Cara mengurutkan record pada sebuah tabel pada waktu
tabel tersebut dibuka dengan bentuk Datasheet View sebagai

berikut:

1. Buka tabel pada bentuk Datasheet View.

2. Klik pada nama field atau judul field yang akan di-

urutkan.

1
2
3
4
5
5]
7
8

(AutoMumber)

Soft drinks, cofl

Sweet and savc
Desserts, cand
Cheeses

Breais, cracke
Prepared meats
Dried fruit and £
Seaweed and fi

Recard: 14] < | 1o e | eifrelEn|rl|of &

Gambar 2.4. Memilih Field yang Akan Diurutkan
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3.

Klik pada ikon Sort Ascending untuk mengurutkan dari
kecil ke besar atau Sort Descending untuk mengurutkan
dari besar ke kecil pada toolbar Microsoft Access.

Records  Tools  Window  Help

Sort Ascending | |Sort Descending

Gambar 2.5. Ikon Sort Ascending dan Descending

15

Mencari Isi Record pada Tabel

Cara mencari isi record pada sebuah tabel sebagai berikut:

1.
2.

3.

24

Buka tabel pada bentuk Datasheet View.
Klik pada ikon Find pada toolbar Microsoft Access.

Gambar 2.6. Ikon Find

Pada kotak dialog Find and Replace, isi record yang akan
dicari pada tabel serta pilih tabel yang digunakan pada
bagian Look In lalu klik Find Next.



Find | Replace: |
Find What:  {_[HUNGO R |
T

Isi Field pm—
Look In: Orders : Table v

Match:

Search:

[ Match Case ¥ | Search Fields &s Formatted

Gambar 2.7. Kotak Dialog Find and Replace
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Membuat Sub Datasheet pada
Tabel

Cara membuat sub datasheet pada tabel sebagai berikut:

1. Buka tabel pada bentuk Datasheet View.
2. Klik pada menu Insert > Subdatasheet.
3. Pilih tabel yang berhubungan yang akan dijadikan sub

tabel beserta field penghubung antara kedua tabel
tersebut pada kotak dialog Insert Subdatasheet. Ke-
mudian klik OK.

20
Tables | ueries | Both |

Link Child Fields: istor_id -
Link Master Fields: — [star_id -

Gambar 2.8. Kotak Dialog Insert Subdatasheet
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4. Contoh hasil sub datasheet terlihat seperti pada Gambar
2.9.

Llaix
stor_id stor_name | stor_address | city I

- 6380 Eric the Read E 788 CatamaugL Seattle WA,

ord_num | ord_date | oty | payterms |

| 6571 14/09/1994 5 Met 60 i

| |[722a 13/09/1994 3 Met B0 F

*

||+ 70ER Barnum's 567 Pasadena . Tustin CA

||+ 707 Mews & Brews 577 First 3t Loz Gatos CA
+17131 Doc-U-Mat: Qu: 24-A Avooadro " Remulade lel

Record: 4| A [T 1 D mipx|@r]of 2 R

Gambar 2.9. Contoh Tampilan Tabel dengan Sub
Datasheet
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Mengatur Tampilan Datasheet
pada Tabel

Cara mengatur tampilan datasheet pada tabel sebagai berikut:
1. Buka tabel pada bentuk Datasheet View.
2. Klik pada menu Format > Datasheet.

3. Atur tampilan yang Anda inginkan dari tabel pada kotak
dialog Datasheet Formatting.
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Datasheet Formatting 2 x|

—Cell Effect —————— ~Gridlines Shown

@ ek W Horzontal
" Raised V' wertical
Cancel |
" Sunken
Background Color: Gridline Color:
| Jwhite | | Tsitver =
—Sample:
—Border and Line Styles
IDatasheet Border j ISolid j

Direction
’76‘ Left-to-right " Right-to-left

Gambar 2.10. Kotak Dialog Datasheet Formatting
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Menyembunyikan Kolom Tabel

Cara menyembunyikan kolom pada tabel sebagai berikut:

1. Buka tabel pada bentuk Datasheet View.

2. Pilih kolom yang akan disembunyikan dengan mengklik
pada nama field seperti terlihat pada Gambar 2.11.

3. Klik pada menu Format > Hide Columns.
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stor_name
Eric the Read |
Barnum's
News & Brews
Doc-U-Mat: Qi
Fricative Books
Bookbeat

Record: 14] ¢ 1 v | rrp#|en|rl | of 6

Gambar 2.11. Memilih Field Tabel yang Akan
Disembunyikan
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Menampilkan Kolom yang
Disembunyikan

Cara menampilkan lagi kolom dari tabel yang disembunyi-
kan sebagai berikut:

1. Buka tabel pada bentuk Datasheet View.
2. Klik pada menu Format > Unhide Columns.

3. Pada kotak dialog Unhide Columns, beri tanda cek
kolom yang akan ditampilkan lagi. Kemudian klik Close.

Unhide Columns 2l
Column: Coss |
tor_id

zip

Gambar 2.12. Kotak Dialog Unhide Columns
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Mengganti Nilai Default dari Tipe
Data Karakter

Cara mengganti nilai default dari tipe data karakter sebagai

berikut:

1. Klik menu Tools > Options.

2. Pada kotak dialog Options tab Tables/Queries, pada
bagian Text ganti nilai default sesuai dengan yang
diinginkan. Kemudian klik OK.

options 20
Wiga I General I Edit/Find I Keyboard I Datashest I Farms/Reports | Pages |
Advanced | Intetnational | Ertar Checking | speling Tables/Queries
Table design
—Default field sizes Default Field type:

Texk: @ Ichar j

Cuery design
—Query design fonk
Fonk:

ITahoma

Nilai Default Untuk
Variabhel Karakter

,TI Cariel | Apply |

Gambar 2.13. Mengganti Nilai Default Tipe Data Karakter
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Membatasi Jumlah Record Tabel

Cara membatasi jumlah record yang dapat ditampung oleh
tabel sebagai berikut:

1. Buka tabel pada bentuk Datasheet view.
2. Klik pada menu Records > Maximum Records.

3. Masukkan jumlah record maksimum dari tabel pada
kotak dialog Set Maximum Record Count. Kemudian
klik OK.

Set Maximum Record Count 2]

Enter the maximum number of records vou would like to have
displaved, Enter O to show all records,

Maimum Record Count:

[o]4 I Cancel |

Gambar 2.14. Membuat Maksimum Jumlah Record Tabel
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Membuat Kopian Tabel Antar-
Database SQL Server dari
Enterprise Manager

Cara membuat kopian tabel antardatabase pada SQL Server
dari Enterprise Manager sebagai berikut:

30



1. Pada database yang akan digunakan, klik-kanan pada
bagian tabel kemudian klik menu All Tasks > Export
Data.

| Tables 35 Items

Mame_/ [ owner [vpe [c
Categories dbo User 0
CustomerCustomerDema dho User 0
CustomerDemographics dho User 0
Customers dbo User 0
depraperties dbo System 1
Employees dho User 0
EmployeeTerritories dho User 0
Order Detais dbo User 0
Procy I bo User o
Reg  USin Table bo User 0
Ship| I * ko User 0
Suppl  Full-Text Index Table » po User 0

Elsysco ormeeess S
Bsysen Manage Indexes...
Elsvsde| copy

Elsysfik  pelete
Elsysfle  Rename Import Data,
Elsysie——————
[Elsysio Properties
Elsvsfu oy | el
Elsysfumermomr—————"—" ganerate 50L Script. .

sysindexes Display Dependencies..

Manage Triggers...
Manage Permissions. .

Create New Publicatior

Gambar 2.15. Menu Export Data

2. Pada kotak dialog DTS Import/Export Wizard, klik
Next.

3. Selanjutnya pilih database tempat tabel tersebut berada.
Klik Next.

4. DTS Import/Export Wizard x|

Choose a Data Source
From where: do you want to copy data? You can copy data from one of the %
fallowing sources.

Data Source: |8 Miciosoit OLE DB Provider for STL Server =

To connect to Micrasoft SOL Server, pou must speciy the server, User
6 T, S e

Server = |
& Use Windows Authentication
£ Use SOL Server Authenlication

U ]

Bassword: [

Diatapase: D [ -] Befesh | Advanced.. |

<Back [ Mew> | Concel | Hep |

Gambar 2.16. Memilih Database Asal Tabel
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4. Selanjutnya pilih database tempat Anda akan membuat
kopian tabel atau database tujuan. Klik Next.

%, DTS Import/Export Wizard x|

Choose a destination
To where do you want to copy data? You can copy data ta one of the following %
destinations.

Destination: IB Microzoft OLE DB Provider for SUL Server j

Ta connect to Micrasoft SOL Server, you must specify the server, user
g natne, and passord

Server Jitocal) 3|

= Use Windows Suthentication
" Use SOL Server Authentication

Username: |
Bassword: [
Databasze: Befiesh Advanced...
Datal Tujuan

<Back [ New> | Concel | Hep |

Gambar 2.17. Memilih Database Tujuan

5. Selanjutnya pilih menu Copy table(s) and view(s) from
the source database. Klik Next.

%, DTS Import/Export Wizard X

Specify Table Copy or Query
Specify whether to copy one of more tables/views of the results of a query from E%

the data source.

5 = 5

Microsoft SEL Server Microsoft SUL Server

& Lopy tablels] and view(s] from the source databasel

= Use a query to specify the data b transfer

(™ Copy abjects and data between SOL Server databases

cBack [ Mews | Coneel | Helo |

Gambar 2.18. Menu Copy table(s) and view(s) from the
source database
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6. Pilih tabel yang akan dikopi.

# DTS Import,/Export Wizard

Select Source Tables and Views

*You can chanse one o more Lables or visws o copy. You Gan copy the schema %
and data as it appears in the sowice or lick (..o transform the data sing

Activel soripts.

Tablels] and “iewls):

Source

[Marthwind] [dbo] [Categories]

O [Morthwind] [dbo] [CustomerCustomerDemo]
O [Morthwind] [dbo] [CustomerDemographics]
[Morthwind]. [dba]. [Customers]
[Morthwind].[dbo]. [Employees]
d] [dba] [EmplayeeT e
I—l Morthwind]. [dbal. [0rdes D etails]
4

| Destination [=]

[LathansL ldbo]_|

[LathanS QL] [dbo]
= [LatihanSOL] [dbo]

SelectAl | Desskctdl | Peviw. |

< Back I Hext > I Cancel | Help

Gambar 2.19. Memilih Tabel

7.  Selanjutnya beri tanda cek pada menu Run immediately.

Klik Next.

4, DTS Import/Export Wizard

x|
Save. schedule. and replicate package

Specify if you want to save this DTS package. You may also replicate the data or E%
schedule the package to be executed at a later time.

[v Run immediatel)t

i

_
f

[~ Use replication to publish destination data

[ Save
Save U1y Packs
i ¢ SO Serverbeta Data Senvices
) Shuctured Storage File
£ isual Basic Fle

< Back I Nest> I Cancel | Help |

Gambar 2.20. Memberi Cek Menu Run Immediately
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8.

Selanjutnya akan terlihat penjelasan dari kopian tabel
yang dibuat pada bagian Summary. Klik Finish.
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Membuat Kopian Tabel Antara
Database SQL Server dan Access
dari Enterprise Manager

Cara membuat kopian tabel antara database pada SQL Server
dan Microsoft Access dari Enterprise Manager sebagai ber-
ikut:

1.

34

Pada database yang akan digunakan, klik-kanan pada
bagian tabel kemudian klik menu All Tasks > Export
Data.

Pada kotak dialog DTS Import/Export Wizard, klik
Next.

Selanjutnya pilih database tempat tabel tersebut berada.
Klik Next.

Kemudian pilih database Microsoft Access pada bagian
Destination dan pilih database access yang akan di-
gunakan sebagai tempat tujuan pada bagian File name
seperti terlihat pada Gambar 2.21. Klik Next.

Selanjutnya pilih menu Copy table(s) and view(s) from
the source database. Klik Next.

Pilih tabel yang akan dikopi.

Selanjutnya beri tanda cek pada menu Run immediately.
Klik Next.



%y DTS Impork,/Export Wizard x|

Choose a destination
To where do you want to copy data? “vou can copy data to one of the following %
destinations.

Destinatior: J&, Microsaft Access =l

& Ta connect, select a database and provide a user name and passward
;,:\% “fou may need to specify advanced options.
e

Eile name: |C.\Ducuments and Settings\Administrator My _I

Uszemame: |

Password: I

Advanced. |
< Back I Hext » I Cancel | Help |

Gambar 2.21. Memilih Database Access Tujuan

8. Selanjutnya akan terlihat penjelasan dari kopian tabel
yang dibuat pada bagian Summary. Klik Finish.
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Mengekspor Record Tabel ke Text
File

Cara mengekspor record dari tabel ke text file sebagai berikut:
1. Buka tabel pada bentuk datasheet view.

2. Klik pada menu File > Export dari menu Microsoft
Access.

3. Selanjutnya pada kotak dialog Export Table, pilih
direktori dan isi nama file pada bagian File name serta
pilih Text Files pada bagian Save as type. Kemudian klik
tombol Export All
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Extport Table Products' s x|

Saveln: [ = Local Disk (C) le-2@ X Tools ~
|1 fYAULTS AvG
ADMINI~1
My Recent ASFRoot
Documents P
v data
m Documents and Settings
Desktop Inetpub
Inprise
z Java
@ JBulders
My Documents | |MSOCache
MYOE10S
% Pragram Files
Temp
Com WINNT
=, Flogame:  (progucts.oxe_J =] I save formattad
My Hetwork ™ Autostart
Places Save as Ly| =) Cancel

Gambar 2.22. Kotak Dialog Export Table

4. Pada kotak dialog Export Text Wizard, pilih bentuk dari
file text tersebut. Kemudian klik Finish.

x

This wizard allows you ko specify details on how Microsoft OFfice Access should export your
data, Which export Format would you like?

" Delimited - Charackers such as comma ot tab separate each Field

() Fixed Width - Fields are aligned in columns with spaces bebwesn each field

Sarple export Format;
|1/t Chai 1 1 10 boxes x |~
LZ Chang 1 1 24 - 12 o=
13| Aniseed 1 2 12 - 550 ml
[als Chef Ant2 2 48 - 6 oz 3
|5 |5 Chef intz 2 36 bhoxes

' _ .
e R R S L .
I i1
ndganced...l Cancel | < Back | Mexk = | FEinish |

Gambar 2.23. Memilih Bentuk Text File
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Mengkonversi Tabel Menjadi Form

Cara mengkonversi tabel menjadi form sebagai berikut:
1.  Pilih tabel yang akan dikonversi menjadi form.

2. Klik menu File > Save As.

3. Pada kotak dialog Save As, isi nama form dan pada

bagian As pilih Form.

savens N 21|
Save Table 'Products’ To: ok I
IForm Products
Cancel

As

IForm j

Gambar 2.24. Mengkonversi Tabel ke Form

4. Klik OK.
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Mengkonversi Tabel Menjadi
Report

Cara mengkonversi tabel menjadi report sebagai berikut:

1.  Pilih tabel yang akan dikonversi menjadi report.

2. Klik menu File > Save As.
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3. Pada kotak dialog Save As, isi nama report dan pada
bagian As pilih Report.

saveas kS
Save Table 'Products' Ta: ok I
IReport Products Cancel |

As

m

Gambar 2.25. Mengkonversi Tabel ke Report

4. Klik OK.
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Membuat Unique Constraint dari
Query Analyzer

Cara membuat unique constraint dari query analyzer sebagai
berikut:

1. Sebagai contoh kita akan membuat tabel dengan mem-
buat unique constraint pada field Alamat. Dengan
demikian pada field Alamat tidak boleh ada data record
yang sama.

2. Contoh perintah SQL untuk membuat unique constraint
terlihat seperti pada Gambar 2.26.
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/ *Menggunakan Database LatihanSQL +/
UZE Latihan3CQL

/ *Membuat tabel thPegawai */

CREATE TAELE thPegawai

[
Kode Char (5],
Harma Char (25) NOT NULL,
/FMenbuat Tnicgque Constraint pada field Llamat */
Alammat  Chari25) NOT NULL CONSTRAINT U_Alamat UNIQUE,
Gaji HNumeric NOT NULL

Gambar 2.26. Membuat Unique Constraint
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Membuat Nilai Default Field Tabel
dari Query Analyzer

Cara membuat nilai default field tabel dari query analyzer
sebagai berikut:

1. Sebagai contoh kita akan membuat tabel dengan mem-
buat nilai default pada field Jabatan. Dengan demikian
pada field Jabatan apabila tidak diisi maka sistem akan
mengisi dengan nilai default-nya.

2. Contoh perintah SQL untuk membuat nilai default
terlihat seperti pada Gambar 2.27.
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/ *Menggunakan Database Latihan3IQL */
T3E LatihanSoL

/ *Hembuat tabel thPegawai */

CREATE TAELE thPegawal

[
Kode Char (5,
Mama Char (25) NOT NULL,
Llamat Char (25) NOT HNULL,
Jakbatan Char (20) DEFAULT 'STAFF',
Gaji Numweric NOT NULL

Gambar 2.27. Membuat Nilai Default pada Field



